re = /(?m-s)^[^"\r\n]*?"note"\h*:\h*"[^"\r\n]*?\d+[^"\r\n]*".*/
str = ' "note" : "",
"note" : "Here is my note",
"note" : "My note $%$",
"note" : "Created bug 14569 in the system",
"note" : "Another beautiful note",
"note" : "@#$%#@%dgdeg"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end