using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"({S[0-9]{2}}[^{}]+)";
string input = @"{S01}1234{S02}字符串字符串{S03}123456";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}