$re = '/({S[0-9]{2}}[^{}]+)/m';
$str = '{S01}1234{S02}字符串字符串{S03}123456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);