package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)({S[0-9]{2}}[^{}]+)`)
var str = `{S01}1234{S02}字符串字符串{S03}123456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}