using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+年\d+月\d+日).*新增本土.*确诊病例(\d+)例.*无症状感染者(\d+)例.*其中(\d+)例确诊病例为此前无症状.*,(\d+)例确诊病例和(\d+)例无症状感染者.*相关风险人群排查中发现";
string input = @"市卫健委今早(22日)通报:2022年4月21日0—24时,新增本土新冠肺炎确诊病例1931例和无症状感染者15698例,其中143例确诊病例为此前无症状感染者转归,1685例确诊病例和15551例无症状感染者在隔离管控中发现,其余在相关风险人群排查中发现
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}