import Foundation
let pattern = #"(\d+年\d+月\d+日).*新增本土.*确诊病例(\d+)例.*无症状感染者(\d+)例.*其中(\d+)例确诊病例为此前无症状.*,(\d+)例确诊病例和(\d+)例无症状感染者.*相关风险人群排查中发现"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
市卫健委今早(22日)通报:2022年4月21日0—24时,新增本土新冠肺炎确诊病例1931例和无症状感染者15698例,其中143例确诊病例为此前无症状感染者转归,1685例确诊病例和15551例无症状感染者在隔离管控中发现,其余在相关风险人群排查中发现
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}