use strict;
my $str = '市卫健委今早(22日)通报:2022年4月21日0—24时,新增本土新冠肺炎确诊病例1931例和无症状感染者15698例,其中143例确诊病例为此前无症状感染者转归,1685例确诊病例和15551例无症状感染者在隔离管控中发现,其余在相关风险人群排查中发现
';
my $regex = qr/(\d+年\d+月\d+日).*新增本土.*确诊病例(\d+)例.*无症状感染者(\d+)例.*其中(\d+)例确诊病例为此前无症状.*,(\d+)例确诊病例和(\d+)例无症状感染者.*相关风险人群排查中发现/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}