using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span class=""icon(.*?)><\/span>";
string input = @"<p style=""text-align: center;""><span style=""font-size: 1em;"">Text 1 <span style=""font-weight: bold;"">TEXT 2</span><span style=""color: #e67e23; font-size: 1.2em;""><span class=""icon x-small icon-play""></span> </span><span style=""color: #e03e2d;"">Text 3</span> <span style=""color: #a68965;"">Text 4 </span></span><span style=""font-size: 0.7em; color: #000000;"">Text 5</span></p>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}