import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<span class=\"icon(.*?)><\\/span>";
final String string = "<p style=\"text-align: center;\"><span style=\"font-size: 1em;\">Text 1 <span style=\"font-weight: bold;\">TEXT 2</span><span style=\"color: #e67e23; font-size: 1.2em;\"><span class=\"icon x-small icon-play\"></span> </span><span style=\"color: #e03e2d;\">Text 3</span> <span style=\"color: #a68965;\">Text 4 </span></span><span style=\"font-size: 0.7em; color: #000000;\">Text 5</span></p>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}