// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<span class="icon(.*?)><\/span>"#).unwrap();
let string = "<p style=\"text-align: center;\"><span style=\"font-size: 1em;\">Text 1 <span style=\"font-weight: bold;\">TEXT 2</span><span style=\"color: #e67e23; font-size: 1.2em;\"><span class=\"icon x-small icon-play\"></span> </span><span style=\"color: #e03e2d;\">Text 3</span> <span style=\"color: #a68965;\">Text 4 </span></span><span style=\"font-size: 0.7em; color: #000000;\">Text 5</span></p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}