import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\s)\\n(?!\\n)";
final String string = "this line should have a break\n"
+ "and this one\n"
+ "but not this one\n\n"
+ "and this one should\n"
+ "and this one\n"
+ "but not this one\n\n"
+ "and so on";
final String subst = " \\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}