use strict;
my $str = 'this line should have a break
and this one
but not this one
and this one should
and this one
but not this one
and so on';
my $regex = qr/(?<!\s)\n(?!\n)/mp;
my $subst = ' \\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";