re = /(?<!\s)\n(?!\n)/m
str = 'this line should have a break
and this one
but not this one
and this one should
and this one
but not this one
and so on'
subst = ' \\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result