import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|\\n\\d+\\))[^)(]*(?:\\([^)(]*(?:\\([^)(]*(?:\\([^)(]*(?:\\([^)(]*\\)[^)(]*)*\\)[^)(]*)*\\)[^)(]*)*\\)[^)(]*)*(?:(?<=\\D)\\)|\\([^)]*(?:\\n|$))";
final String string = "Текст текст текст. Список:\n\n"
+ "1) пункт первый\n"
+ "2) пункт второй\n"
+ "3) пункт третий\n"
+ "228) наркопункт\n"
+ "1337) элитный пункт\n"
+ " Текст (текст (в (скобках) ещё (текст) в) скобках) текст.\n"
+ "1488) наципункт\n\n"
+ "Скобкодаун тешится)))\n"
+ "Скобкодаун грустит(((";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}