const regex = /(?:^|\n\d+\))[^)(]*(?:\([^)(]*(?:\([^)(]*(?:\([^)(]*(?:\([^)(]*\)[^)(]*)*\)[^)(]*)*\)[^)(]*)*\)[^)(]*)*(?:(?<=\D)\)|\([^)]*(?:\n|$))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|\\n\\d+\\))[^)(]*(?:\\([^)(]*(?:\\([^)(]*(?:\\([^)(]*(?:\\([^)(]*\\)[^)(]*)*\\)[^)(]*)*\\)[^)(]*)*\\)[^)(]*)*(?:(?<=\\D)\\)|\\([^)]*(?:\\n|$))', 'g')
const str = `Текст текст текст. Список:
1) пункт первый
2) пункт второй
3) пункт третий
228) наркопункт
1337) элитный пункт
Текст (текст (в (скобках) ещё (текст) в) скобках) текст.
1488) наципункт
Скобкодаун тешится)))
Скобкодаун грустит(((`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}