re = /(?:^|\n\d+\))[^)(]*(?:\([^)(]*(?:\([^)(]*(?:\([^)(]*(?:\([^)(]*\)[^)(]*)*\)[^)(]*)*\)[^)(]*)*\)[^)(]*)*(?:(?<=\D)\)|\([^)]*(?:\n|$))/
str = 'Текст текст текст. Список:
1) пункт первый
2) пункт второй
3) пункт третий
228) наркопункт
1337) элитный пункт
Текст (текст (в (скобках) ещё (текст) в) скобках) текст.
1488) наципункт
Скобкодаун тешится)))
Скобкодаун грустит((('
# Print the match result
str.scan(re) do |match|
puts match.to_s
end