using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*h.*a.*c.*k.*e.*r.*r.*a.*n.*k.*";
string input = @"hackerworld";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}