package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*h.*a.*c.*k.*e.*r.*r.*a.*n.*k.*`)
var str = `hackerworld`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}