$re = '/.*h.*a.*c.*k.*e.*r.*r.*a.*n.*k.*/m';
$str = 'hackerworld';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);