package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d\D?){10}\d$`)
var str = `1 1 1 1 1 1 1 1 1 1 1
11111111111
1-1111111111
1.1.1.1.1.1.1.1.1.1.1
1 1 1 1 1 1 1 1 1 1 1
1--1111111111`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}