re = /^(\d\D?){10}\d$/m
str = '1 1 1 1 1 1 1 1 1 1 1
11111111111
1-1111111111
1.1.1.1.1.1.1.1.1.1.1
1 1 1 1 1 1 1 1 1 1 1
1--1111111111'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end