package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\]\s+(?<service>[^ ]+)\s+(?<status>[^ ]+)`)
var str = `[2020-07-07 12:40:01+0200] workspace_sandbox RUNNING pid 17159, uptime 21 days, 21:43:58`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}