const regex = /\]\s+(?<service>[^ ]+)\s+(?<status>[^ ]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\]\\s+(?<service>[^ ]+)\\s+(?<status>[^ ]+)', 'gm')
const str = `[2020-07-07 12:40:01+0200] workspace_sandbox RUNNING pid 17159, uptime 21 days, 21:43:58`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}