$re = '/\]\s+(?<service>[^ ]+)\s+(?<status>[^ ]+)/m';
$str = '[2020-07-07 12:40:01+0200] workspace_sandbox RUNNING pid 17159, uptime 21 days, 21:43:58';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);