#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*(?=.*tag_patchwave_2.*).*(?=.*azure_loc_westeurope.*).*|.*(?=.*tag_patchwave_2.*).*(?=.*azure_loc_ukwest.*).*|US2AZAWXVMP01)"
Local $sString = "US2AZAWXVMP01" & @CRLF & _
"azure_loc_ukwest tag_patchwave_2 " & @CRLF & _
"tag_patchwave_2 azure_loc_westeurope"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")