using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*(?=.*tag_patchwave_2.*).*(?=.*azure_loc_westeurope.*).*|.*(?=.*tag_patchwave_2.*).*(?=.*azure_loc_ukwest.*).*|US2AZAWXVMP01)";
string input = @"US2AZAWXVMP01
azure_loc_ukwest tag_patchwave_2
tag_patchwave_2 azure_loc_westeurope";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}