$re = '/(.*(?=.*tag_patchwave_2.*).*(?=.*azure_loc_westeurope.*).*|.*(?=.*tag_patchwave_2.*).*(?=.*azure_loc_ukwest.*).*|US2AZAWXVMP01)/m';
$str = 'US2AZAWXVMP01
azure_loc_ukwest tag_patchwave_2
tag_patchwave_2 azure_loc_westeurope';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);