package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{1,2}\/\d{2}\/19(?:[6-8]\d|9[0-5])`)
var str = `dddsda 1/21/1950 ddwqq`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}