const regex = /\d{1,2}\/\d{2}\/19(?:[6-8]\d|9[0-5])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{1,2}\\\/\\d{2}\\\/19(?:[6-8]\\d|9[0-5])', 'gm')
const str = `dddsda 1/21/1950 ddwqq`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}