$re = '/\d{1,2}\/\d{2}\/19(?:[6-8]\d|9[0-5])/m';
$str = 'dddsda 1/21/1950 ddwqq';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);