using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Fields\(""(\w+)""\)\.Value\)*?";
string input = @"Function lmpRoundedEndTime_ValueChanged(sender, e)
If CDbl(Fields(""lmpShiftID"").Value) <> 0 And IsNull(Fields(""lmpRoundedStartTime"").Value) = False And IsNull(Fields(""lmpRoundedEndTime"").Value) = False Then
If CInt(App.Props(""PN"").Fields(""xapDCPayCalculationMethod"").Value) <> 2 Then
Fields(""lmpPayrollHours"").Value = App.Ax(""TimecardFunctions"").CalculateHours(Fields(""lmpShiftID"").Value,Fields(""lmpRoundedStartTime"").Value,Fields(""lmpRoundedEndTime"").Value)
End If
End If
End Function";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}