// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)Fields\("(\w+)"\)\.Value\)*?"#).unwrap();
let string = "Function lmpRoundedEndTime_ValueChanged(sender, e)
If CDbl(Fields(\"lmpShiftID\").Value) <> 0 And IsNull(Fields(\"lmpRoundedStartTime\").Value) = False And IsNull(Fields(\"lmpRoundedEndTime\").Value) = False Then
If CInt(App.Props(\"PN\").Fields(\"xapDCPayCalculationMethod\").Value) <> 2 Then
Fields(\"lmpPayrollHours\").Value = App.Ax(\"TimecardFunctions\").CalculateHours(Fields(\"lmpShiftID\").Value,Fields(\"lmpRoundedStartTime\").Value,Fields(\"lmpRoundedEndTime\").Value)
End If
End If
End Function";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}