$re = '/Fields\("(\w+)"\)\.Value\)*?/m';
$str = 'Function lmpRoundedEndTime_ValueChanged(sender, e)
If CDbl(Fields("lmpShiftID").Value) <> 0 And IsNull(Fields("lmpRoundedStartTime").Value) = False And IsNull(Fields("lmpRoundedEndTime").Value) = False Then
If CInt(App.Props("PN").Fields("xapDCPayCalculationMethod").Value) <> 2 Then
Fields("lmpPayrollHours").Value = App.Ax("TimecardFunctions").CalculateHours(Fields("lmpShiftID").Value,Fields("lmpRoundedStartTime").Value,Fields("lmpRoundedEndTime").Value)
End If
End If
End Function';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);