#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\b\d{1,2}[-|–|—|\s|(?:\sde\s|\sdel\s)|\d+/](?:Ene|Enero|Feb|Febrero|Mar|Marzo|Abril|Mayo|May|Jun|Junio|Jul|Julio|Ago|Agosto|Sep|Sept|Septiembre|Oct|Octubre|Nov|Noviembre|Dic|Diciembre|\d+)[-|–|—|\s|(?:\sde\s|\sdel\s)|\d+/](?:\d{4}|\d{2})\b"
Local $sString = "04/13/07 " & @CRLF & _
"" & @CRLF & _
"21 diciembre 2012 " & @CRLF & _
"" & @CRLF & _
"08-Ene—07 " & @CRLF & _
"" & @CRLF & _
"17-Feb-2014 " & @CRLF & _
"" & @CRLF & _
"21 ene 2012 " & @CRLF & _
"" & @CRLF & _
"04-13-07" & @CRLF & _
"" & @CRLF & _
"04 13 07" & @CRLF & _
"" & @CRLF & _
"11 de Noviembre de 2013 [missing]" & @CRLF & _
"" & @CRLF & _
"23 de noviembre del 2011 [missing]" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")