re = /(?i)\b\d{1,2}[-|–|—|\s|(?:\sde\s|\sdel\s)|\d+\/](?:Ene|Enero|Feb|Febrero|Mar|Marzo|Abril|Mayo|May|Jun|Junio|Jul|Julio|Ago|Agosto|Sep|Sept|Septiembre|Oct|Octubre|Nov|Noviembre|Dic|Diciembre|\d+)[-|–|—|\s|(?:\sde\s|\sdel\s)|\d+\/](?:\d{4}|\d{2})\b/
str = '04/13/07
21 diciembre 2012
08-Ene—07
17-Feb-2014
21 ene 2012
04-13-07
04 13 07
11 de Noviembre de 2013 [missing]
23 de noviembre del 2011 [missing]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end