#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^|(?<=\s))(?!1?\d{10}@)(\w[\w\.]*@\w+\.[\w\.]+)\b"
Local $sString = "123456789@test.com // allowed (9 digits or less)" & @CRLF & _
"01234567890@test.com // allowed (11 digits but not starting with 1)" & @CRLF & _
"123456789012@test.com // allowed (12 digits or more)" & @CRLF & _
"" & @CRLF & _
"0123456789@test.com // NOT allowed (10 digits)" & @CRLF & _
"11234567890@test.com // NOT allowed (11 digits and starting with 1)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")