import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|(?<=\\s))(?!1?\\d{10}@)(\\w[\\w\\.]*@\\w+\\.[\\w\\.]+)\\b";
final String string = "123456789@test.com // allowed (9 digits or less)\n"
+ "01234567890@test.com // allowed (11 digits but not starting with 1)\n"
+ "123456789012@test.com // allowed (12 digits or more)\n\n"
+ "0123456789@test.com // NOT allowed (10 digits)\n"
+ "11234567890@test.com // NOT allowed (11 digits and starting with 1)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}