import re
regex = re.compile(r"(?:^|(?<=\s))(?!1?\d{10}@)(\w[\w\.]*@\w+\.[\w\.]+)\b", flags=re.MULTILINE)
test_str = ("123456789@test.com // allowed (9 digits or less)\n"
"01234567890@test.com // allowed (11 digits but not starting with 1)\n"
"123456789012@test.com // allowed (12 digits or more)\n\n"
"0123456789@test.com // NOT allowed (10 digits)\n"
"11234567890@test.com // NOT allowed (11 digits and starting with 1)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")