use strict;
my $str = 'hello: Mister, Winterbottom';
my $regex = qr/[\s,:]+/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";