import re
regex = re.compile(r"[\s,:]+")
test_str = "hello: Mister, Winterbottom"
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)