$re = '/^(\d+\.?\d+|\d)$/m';
$str = '123.321
123..123
1.2.3.4
123.333.123
12389329
1
.123
123.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);