re = /^(\d+\.?\d+|\d)$/m
str = '123.321
123..123
1.2.3.4
123.333.123
12389329
1
.123
123.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end