package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<([^\/>]+)>.*?<.*?\/.*?>`)
var str = `Какой то текст <id>Теги и</id> текст которые нужно удалить</id>. Какой то текст<id>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}