$re = '/<([^\/>]+)>.*?<.*?\/.*?>/i';
$str = 'Какой то текст <id>Теги и</id> текст которые нужно удалить</id>. Какой то текст<id>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);