#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "{([\s\S]+?)}"
Local $sString = "{0}{5}" & @CRLF & _
"{1}{dfdf}" & @CRLF & _
"{2}{пара, пара п.а пара&па®}" & @CRLF & _
"{3}{dfdf!}"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)