using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{([\s\S]+?)}";
string substitution = @"$1";
string input = @"{0}{5}
{1}{dfdf}
{2}{пара, пара п.а пара&па®}
{3}{dfdf!}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}