const regex = /{([\s\S]+?)}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{([\\s\\S]+?)}', 'g')
const str = `{0}{5}
{1}{dfdf}
{2}{пара, пара п.а пара&па®}
{3}{dfdf!}`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);