$re = '/"(?<!\')(.*?)(?<!\\\\)(?<!\')"/m';
$str = '$str = "this is something";
$str = "this is {$another}";
$str = "could be {$hello[\'world\']}";
$str = "and $hello[world] another";
$str = "building <div style=\\"width: 100%\\" data-var=\\"{$var}\\"></div>";
$str = \'<elem prop="\' . $var . \'">\';
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);