const regex = /(?<function>\w+) \( # Matches function name
(?<parameters> # Simple param type.
(?<data> # Simple data type: inner function or word (keep this order!).
(?R) | # Or recursive this Regexp to match inner functions.
\w+ # Matches a simple word.
)
( # Match additional parameters:
\s*,\s* # Match comma, but skip spaces.
\g<parameters> # Recurse additional parameters.
)* # Zero or more additional parameters.
)? # Parameters are optional
\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<function>\\w+) \\( # Matches function name
(?<parameters> # Simple param type.
(?<data> # Simple data type: inner function or word (keep this order!).
(?R) | # Or recursive this Regexp to match inner functions.
\\w+ # Matches a simple word.
)
( # Match additional parameters:
\\s*,\\s* # Match comma, but skip spaces.
\\g<parameters> # Recurse additional parameters.
)* # Zero or more additional parameters.
)? # Parameters are optional
\\)', 'gm')
const str = `color()
color(a)
color(a, a)
color(a())
color(a(b()))
color(a, a())
color(a, a(), b)
color(a(), b)
color(a, b, c(d, e(f, g()), h))`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}