re = /(?<function>\w+) \( # Matches function name
(?<parameters> # Simple param type.
(?<data> # Simple data type: inner function or word (keep this order!).
(?R) | # Or recursive this Regexp to match inner functions.
\w+ # Matches a simple word.
)
( # Match additional parameters:
\s*,\s* # Match comma, but skip spaces.
\g<parameters> # Recurse additional parameters.
)* # Zero or more additional parameters.
)? # Parameters are optional
\)/mx
str = 'color()
color(a)
color(a, a)
color(a())
color(a(b()))
color(a, a())
color(a, a(), b)
color(a(), b)
color(a, b, c(d, e(f, g()), h))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end